Results 1 to 5 of 5

Thread: Sometimes buggy kauction

  1. #1

    Default Sometimes buggy kauction

    Every so often I get this lua error, which seems mostly associated with offspec auto bids. At least, all the times I've noticed it, it's been with offspec auto bids...

    Date: 2012-04-18 18:59:25
    ID: 54
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\kAuction\Gui\CurrentItem.lua line 175:
    Usage: kAuctionCurrentItemFrameItemContainerIcon:SetNorma lTexture(texture or "texture" or nil)
    Debug:
    (tail call): ?
    [C]: SetNormalTexture()
    kAuction\Gui\CurrentItem.lua:175: Gui_CreateCurrentItemFrame()
    kAuction\Gui\Core.lua:63: Gui_OnClickAuctionBidButton()
    kAuction\Client\Core.lua:67: Client_AuctionReceived()
    kAuction\Core.lua:295: ?()
    ...que\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147:
    ...que\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147
    [string "safecall Dispatcher[4]"]:4:
    [string "safecall Dispatcher[4]"]:4
    [C]: ?
    [string "safecall Dispatcher[4]"]:13: ?()
    ...que\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: Fire()
    ...face\AddOns\Recount\Libs\AceComm-3.0\AceComm-3.0.lua:247: OnReceiveMultipartLast()
    ...face\AddOns\Recount\Libs\AceComm-3.0\AceComm-3.0.lua:331:
    ...face\AddOns\Recount\Libs\AceComm-3.0\AceComm-3.0.lua:321

  2. #2

    Default

    Sweet thanks for the report Tree. That should be fixed now in the latest release: http://wow.curseforge.com/addons/kauction/

  3. #3

    Default

    I've been getting another error lately with offspec auto bids;

    Date: 2012-06-18 20:30:06
    ID: 49
    Error occured in: Global
    Count: 1
    Message: ..\AddOns\kAuction\Gui\CurrentItem.lua line 175:
    Usage: kAuctionCurrentItemFrameItemContainerIcon:SetNorma lTexture(texture or "texture" or nil)
    Debug:
    (tail call): ?
    [C]: SetNormalTexture()
    kAuction\Gui\CurrentItem.lua:175: Gui_CreateCurrentItemFrame()
    kAuction\Gui\Core.lua:63: Gui_OnClickAuctionBidButton()
    kAuction\Client\Core.lua:67: Client_AuctionReceived()
    kAuction\Core.lua:295: ?()
    ...que\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147:
    ...que\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:147
    [string "safecall Dispatcher[4]"]:4:
    [string "safecall Dispatcher[4]"]:4
    [C]: ?
    [string "safecall Dispatcher[4]"]:13: ?()
    ...que\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:92: Fire()
    ...face\AddOns\Recount\Libs\AceComm-3.0\AceComm-3.0.lua:247: OnReceiveMultipartLast()
    ...face\AddOns\Recount\Libs\AceComm-3.0\AceComm-3.0.lua:331:
    ...face\AddOns\Recount\Libs\AceComm-3.0\AceComm-3.0.lua:321
    I'm no code-junkie, but it appears to be the same general error?... If so, not sure why. I updated kauction right after you uploaded the last fix O_o
    Last edited by Tree; 06-19-2012 at 09:09 AM.

  4. #4

    Default

    Hard for me to test these bugs sometimes, but latest release may have fixed this one. Let me know if not Tree!

  5. #5

    Default

    New build (r73) is required if you grabbed the update in the last 7 hours (r72) after my last post. Major typo causes shit to completely break, so please grab latest release to fix if needed. ><

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •